16.6. bdb

Possible arguments: (none), 48, 5 (default), 6

Add dependency on the Berkeley DB library. Default to databases/db5. It can also depend on databases/db48 when using the :48 argument or databases/db6 with :6. It is possible to declare a range of acceptable values, :48+ finds the highest installed version, and falls back to 4.8 if nothing else is installed. INVALID_BDB_VER can be used to specify versions which do not work with this port. The framework exposes the following variables to the port:

BDB_LIB_NAME

The name of the Berkeley DB library. For example, when using databases/db5, it contains db-5.3.

BDB_LIB_CXX_NAME

The name of the Berkeley DB C++ library. For example, when using databases/db5, it contains db_cxx-5.3.

BDB_INCLUDE_DIR

The location of the Berkeley DB include directory. For example, when using databases/db5, it will contain ${LOCALBASE}/include/db5.

BDB_LIB_DIR

The location of the Berkeley DB library directory. For example, when using databases/db5, it contains ${LOCALBASE}/lib.

BDB_VER

The detected Berkeley DB version. For example, if using USES=bdb:48+ and Berkeley DB 5 is installed, it contains 5.

Important:

databases/db48 is deprecated and unsupported. It must not be used by any port.

All FreeBSD documents are available for download at https://download.freebsd.org/ftp/doc/

Questions that are not answered by the documentation may be sent to <freebsd-questions@FreeBSD.org>.
Send questions about this document to <freebsd-doc@FreeBSD.org>.